Hosted Pages Access Issues
Resolved
Oct 20 at 08:06pm BST
This Issue is now resolved and the Hosted pages are back up and fully operational.
Thank you for your patience
Affected services
Created
Oct 20 at 04:45pm BST
We are aware of an ongoing issue affecting some hosted pages, resulting in 500 and 504 errors for certain customers. This issue is also impacting site publishing and access to the Webflow Dashboard.
Our upstream provider experienced a disruption earlier today, and while services have largely recovered, we’re continuing to monitor for any remaining impact to hosted sites.
Our team is actively working with Webflow to ensure full restoration of service. We’ll provide further updates as soon as more information becomes available.
Affected services